Contact Us!

    Full Name (Required)

    Telephone No. (Required)

    Email Address (Required)

    Areas of Interest (Required)


    Subject

    Message

    Contact Us

    sup[email protected]

    Worcester, MA | 866-304-4300

    Boston, MA | 508-365-3630

    Providence, RI | 401-735-1956

    Hartford, CT | 860-560-8000

    The Internet Explorer vulnerability (CVE-2019-1367) is a critical zero-day bug.

    I mean now, right now, uninstall it – every version of Internet Explorer needs to be removed. On Monday, September 23, Microsoft made an announcement and immediately deployed out-of-band updates for Internet Explorer. This update prevents a script from executing without any interaction by the user. A simple visit to a website can compromise your computer.

    Read More